Hello Guest

Stuck at WOT - KTM520

  • 8 Replies
  • 2308 Views

0 Members and 1 Guest are viewing this topic.

*

dylanfan53

  • ******
  • 1470
    +136/-154
  • My boots are squishy!
Stuck at WOT - KTM520
« on: October 15, 2008, 08:58:37 pm »
My nephew has a problem that maybe someone out there can help with.  He just had his KTM 520 motor rebuilt after dropping a valve (I think it was).  When he reinstalled it and took it for a ride it ran rough at idle, then all of a sudden it ran at WOT.  He thought it was a stuck cable but has removed and replaced the carb twice and still has the same problem.  Everything looks normal (slides, needle, cables look free and clear) but when he kicks it over it starts up wide open.

My thought is that it has to be in the carb somewhere so he has to go through it again, but since he's already gone that route a couple of times I thought I'd throw the question out there for any ideas about most likely causes or where else to look.  Anyone? 

Thanks.  Maybe if I help he'll teach me some stunts.  :cheers:     
Like
0
Dislike
0
Agree
0
Disagree
0
No reactions
No reactions
No reactions
No reactions
Don Cook
CCS #53

*

Super Dave

  • I hate salad...
  • ******
  • 11415
    +1261/-454
  • I'm the ghost with the most...
Re: Stuck at WOT - KTM520
« Reply #1 on: October 16, 2008, 06:33:47 am »
I'd look for a vacuum leak.  Shouldn't run wide open with the slide in the lower position unless there's a way to get more air inside.
Like
0
Dislike
0
Agree
0
Disagree
0
No reactions
No reactions
No reactions
No reactions
Super Dave

*

EX_#76

  • *****
  • 862
    +224/-127
  • Wooooo Hooooo!!!!
Re: Stuck at WOT - KTM520
« Reply #2 on: October 16, 2008, 09:03:38 am »
My nephew has a problem that maybe someone out there can help with.  He just had his KTM 520 motor rebuilt after dropping a valve (I think it was).  When he reinstalled it and took it for a ride it ran rough at idle, then all of a sudden it ran at WOT.  He thought it was a stuck cable but has removed and replaced the carb twice and still has the same problem.  Everything looks normal (slides, needle, cables look free and clear) but when he kicks it over it starts up wide open.

My thought is that it has to be in the carb somewhere so he has to go through it again, but since he's already gone that route a couple of times I thought I'd throw the question out there for any ideas about most likely causes or where else to look.  Anyone? 

Thanks.  Maybe if I help he'll teach me some stunts.  :cheers:    

Don,
     Do a sanity check on the carb.  Double check that you are aligning the slot in the side of the slide (assuming that it is a slide type carb) with the alignment pin in the slide bore of the carb.  I have seen these misaligned and the the engine will rev like crazy when you start it.
     
    Dave is right, assuming the source of you problem is not the carb, the most likely cause is a vacuum leak.  I am not familiar with this particular bike but I would take a close look at the gaskets and or o-rings that seal the carb and or intake boot to the engine.  Check for any cracks in the intake boot and look for any missing plugs on vacuum taps along the way.


Keep us posted
Guy
Like
0
Dislike
0
Agree
0
Disagree
0
No reactions
No reactions
No reactions
No reactions
Guy Bartz
MW EX #76
Mass Reduction LLC Home of the Grip Doctor

*

dylanfan53

  • ******
  • 1470
    +136/-154
  • My boots are squishy!
Re: Stuck at WOT - KTM520
« Reply #3 on: October 16, 2008, 08:05:29 pm »
Thanks guys.  I'll pass the word along and we'll check for leaks.
Like
0
Dislike
0
Agree
0
Disagree
0
No reactions
No reactions
No reactions
No reactions
Don Cook
CCS #53

*

GSXR RACER MIKE

  • *
  • 1847
    +135/-134
  • Slow guy!
Re: Stuck at WOT - KTM520
« Reply #4 on: October 16, 2008, 11:52:23 pm »
Just to throw something else out there, how about the float? A stuck float could be letting extra fuel up into the intake area causing a rich situation at idle and going WOT when some throttle is applied and some air gets flowing thru there to let that extra fuel burn. If it's a gravity feed system I think it would overflow fuel even when shut off, but if it has a fuel pump or some other type of fuel flow limiting device then it may only happen when running.

The problem I have with it just being a vacuum leak is that it would still need extra fuel to allow it to go WOT - extra air and no extra fuel shouldn't cause it to rev. The intake on my 3-wheeler once came loose where it connected to the head and that actually caused it to run bad (lean out), not go WOT. If a vacuum related problem was somehow allowing extra fuel to enter the intake tract then I could see the WOT problem.
Like
0
Dislike
0
Agree
0
Disagree
0
No reactions
No reactions
No reactions
No reactions
Smites are a cowards way of feeling brave!   :jerkoff:
Mike Williams - 2 GSXR 750's
Former MW Region Expert #58
Racing exclusively with CCS since '96
MODERATOR

*

dylanfan53

  • ******
  • 1470
    +136/-154
  • My boots are squishy!
Re: Stuck at WOT - KTM520
« Reply #5 on: October 17, 2008, 10:26:44 pm »
Thanks Mike.  I'll run down there and check it out this weekend.
Like
0
Dislike
0
Agree
0
Disagree
0
No reactions
No reactions
No reactions
No reactions
Don Cook
CCS #53

*

mikendzel

  • ****
  • 308
    +138/-9
  • Broken wrist = no racey
    • B&E Motorsports
Re: Stuck at WOT - KTM520
« Reply #6 on: October 22, 2008, 10:25:30 am »
Call Bob @ B&E Motorsports    (410) 827-3792   www.bemotorsports.net

He's great people, ridiculously nice, a CCS Expert, and a KTM authorized dealer.
Like
0
Dislike
0
Agree
0
Disagree
0
No reactions
No reactions
No reactions
No reactions

*

EX_#76

  • *****
  • 862
    +224/-127
  • Wooooo Hooooo!!!!
Re: Stuck at WOT - KTM520
« Reply #7 on: October 22, 2008, 01:07:53 pm »
Thanks Mike.  I'll run down there and check it out this weekend.

Any updates?
Like
0
Dislike
0
Agree
0
Disagree
0
No reactions
No reactions
No reactions
No reactions
Guy Bartz
MW EX #76
Mass Reduction LLC Home of the Grip Doctor

*

dylanfan53

  • ******
  • 1470
    +136/-154
  • My boots are squishy!
Re: Stuck at WOT - KTM520
« Reply #8 on: October 27, 2008, 08:17:01 pm »
Thanks guys.  He's riding his other bike so he hasn't gotten around to it again yet.  I'll post up when I have the scoop.
Like
0
Dislike
0
Agree
0
Disagree
0
No reactions
No reactions
No reactions
No reactions
Don Cook
CCS #53